aboutsummaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorpacien2020-09-09 18:56:25 +0200
committerpacien2020-09-10 01:16:36 +0200
commit1c71b4c2e9f9d396cb67aecf581b3d518be0ac9c (patch)
tree4e5ccc99aaaf7042dad8f6feef5a09c098ed79d7 /app/CMakeLists.txt
parenta77ccf998d3fc90496d0c184d90f71aebda899c3 (diff)
downloadtincapp-1c71b4c2e9f9d396cb67aecf581b3d518be0ac9c.tar.gz
tinc: fix FORTIFY error when initialising a new tinc configuration
This fixes the "FORTIFY: umask: called with invalid mask -601" error when attempting to create a new tinc configuration on builds having the FORTIFY option enabled (by default in NDK >=r21). Upstream patch: https://github.com/gsliepen/tinc/pull/251 GitHub: closes #99
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 6511df1..1962fbf 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -56,6 +56,8 @@ ExternalProject_Add(tinc
56 DEPENDS lzo libressl 56 DEPENDS lzo libressl
57 URL https://github.com/gsliepen/tinc/archive/f5223937e62e1cc5e9b3d322490dd3af8d666750.tar.gz 57 URL https://github.com/gsliepen/tinc/archive/f5223937e62e1cc5e9b3d322490dd3af8d666750.tar.gz
58 URL_HASH SHA256=3fe923e8fbb1e0192986039e91d6945ffbbe326ee8c2c0a13bacf80e87dad4a9 58 URL_HASH SHA256=3fe923e8fbb1e0192986039e91d6945ffbbe326ee8c2c0a13bacf80e87dad4a9
59 # TODO: remove patch once merged in upstream (https://github.com/gsliepen/tinc/pull/251)
60 PATCH_COMMAND patch -p1 < ${PROJECT_SOURCE_DIR}/src/main/c/0001-tincctl-restrict-umask-argument-for-FORTIFY.patch
59 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && 61 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> &&
60 <SOURCE_DIR>/configure ${xCONFIG} 62 <SOURCE_DIR>/configure ${xCONFIG}
61 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local 63 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local