aboutsummaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorpacien2021-07-12 00:14:32 +0200
committerpacien2021-07-12 00:14:32 +0200
commit66b3fcbc5069335770a6fb57021343232c354f78 (patch)
tree9b5df56216419ac983710b65aca4ea64e63ae11d /app/CMakeLists.txt
parentc1d2e62664768477b2061a89b5b19a2a80dfb02b (diff)
downloadtincapp-66b3fcbc5069335770a6fb57021343232c354f78.tar.gz
deps: update tinc to 1.1pre18
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index b4853eb..181a27a 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -54,10 +54,8 @@ ExternalProject_Add(libressl
54 54
55ExternalProject_Add(tinc 55ExternalProject_Add(tinc
56 DEPENDS lzo libressl 56 DEPENDS lzo libressl
57 URL https://github.com/gsliepen/tinc/archive/3ee0d5dddb56a13b8f3c50637e3cd075c701c9aa.tar.gz 57 URL https://tinc-vpn.org/packages/tinc-1.1pre18.tar.gz
58 URL_HASH SHA256=3a901e7e59d50675b311087ea202f5e409bf69df91d09d7798a0813f3ec05e13 58 URL_HASH SHA256=2757ddc62cf64b411f569db2fa85c25ec846c0db110023f6befb33691f078986
59 # TODO: remove patch once merged in upstream (https://github.com/gsliepen/tinc/pull/251)
60 PATCH_COMMAND patch -p1 < ${PROJECT_SOURCE_DIR}/src/main/c/0001-tincctl-restrict-umask-argument-for-FORTIFY.patch
61 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && 59 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> &&
62 <SOURCE_DIR>/configure ${xCONFIG} 60 <SOURCE_DIR>/configure ${xCONFIG}
63 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local 61 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local