aboutsummaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorpacien2020-01-20 17:07:12 +0100
committerpacien2020-01-20 17:07:12 +0100
commit883b5abc7b2a770146683e7e27bf275bd4064511 (patch)
tree81dd200fc2cea8e2030b5b5b68c39abe3c32ab46 /app/CMakeLists.txt
parent3fc8a2ed3bfbcbd29bc22c2c73416e2708cd7615 (diff)
downloadtincapp-883b5abc7b2a770146683e7e27bf275bd4064511.tar.gz
pass network device fd via unix socket instead of inheritance
Workaround for new shared memory restrictions added in Android 10 preventing file descriptor leakage to sub-processes. This change set BREAKS ENCRYPTED PRIVATE KEYS SUPPORT. GitHub: https://github.com/pacien/tincapp/issues/92
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 073f7d7..6449aeb 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -54,9 +54,8 @@ ExternalProject_Add(libressl
54 54
55ExternalProject_Add(tinc 55ExternalProject_Add(tinc
56 DEPENDS lzo libressl 56 DEPENDS lzo libressl
57 URL https://github.com/gsliepen/tinc/archive/017a7fb57655d9b1d706ee78f7e3d0000411b883.tar.gz 57 URL https://github.com/gsliepen/tinc/archive/6682a0d29cbb70b216a3fe02f2812963dee607d0.tar.gz
58 URL_HASH SHA256=27f361706d09f81fbbef7021f37adf5375f01857b23272a490df066ca290a530 58 URL_HASH SHA256=ffb0e6c02b0112c095366b3baa89f5ed56cc5f644be40268696ce7741e76452a
59 PATCH_COMMAND sed -i -e "s/test(void)/test(void *x)/" <SOURCE_DIR>/m4/attribute.m4
60 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && 59 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> &&
61 <SOURCE_DIR>/configure ${xCONFIG} 60 <SOURCE_DIR>/configure ${xCONFIG}
62 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local 61 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local
@@ -72,5 +71,5 @@ ExternalProject_Add(tinc
72 rm -r <BINARY_DIR> 71 rm -r <BINARY_DIR>
73) 72)
74 73
75add_library(exec SHARED src/main/c/exec.c) 74add_library(main SHARED src/main/c/main.c)
76add_dependencies(exec tinc) 75add_dependencies(main tinc)