aboutsummaryrefslogtreecommitdiff
path: root/lib/mk-sandbox-system.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mk-sandbox-system.nix')
-rw-r--r--lib/mk-sandbox-system.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/lib/mk-sandbox-system.nix b/lib/mk-sandbox-system.nix
index 3bbc488..1e1c596 100644
--- a/lib/mk-sandbox-system.nix
+++ b/lib/mk-sandbox-system.nix
@@ -6,7 +6,6 @@ flake:
6, tools ? [] 6, tools ? []
7, envVars ? { } 7, envVars ? { }
8, restrictNetwork ? true # to be replaced with virtualisation.restrictNetwork 8, restrictNetwork ? true # to be replaced with virtualisation.restrictNetwork
9, patchQemu9p ? false # until qemu 7.2.0 becomes available in nixpkgs
10}@params: 9}@params:
11 10
12let 11let
@@ -116,21 +115,6 @@ in rec {
116 # https://github.com/NixOS/nixpkgs/pull/200225 115 # https://github.com/NixOS/nixpkgs/pull/200225
117 #restrictNetwork = lib.mkDefault true; 116 #restrictNetwork = lib.mkDefault true;
118 117
119 # Patched QEMU to fix slow 9p file share.
120 # https://linus.schreibt.jetzt/posts/qemu-9p-performance.html
121 qemu.package = lib.mkDefault (
122 if patchQemu9p then
123 assert !(pkgs.lib.versionAtLeast pkgs.qemu_kvm.version "7.2.0");
124 pkgs.qemu_kvm.overrideAttrs (o: {
125 patches = o.patches ++ [ (pkgs.fetchpatch {
126 name = "qemu-9p-performance-fix.patch";
127 url = "https://github.com/qemu/qemu/commit/f5265c8.patch";
128 sha256 = "sha256-PSOv0dhiEq9g6B1uIbs6vbhGr7BQWCtAoLHnk4vnvVg=";
129 }) ];
130 })
131 else pkgs.qemu_kvm
132 );
133
134 }; 118 };
135 }); 119 });
136 120