aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index a5a4f46..bb31db2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -20,8 +20,7 @@
20 description = "A static web gallery generator with tags"; 20 description = "A static web gallery generator with tags";
21 21
22 inputs = { 22 inputs = {
23 # GHC 9.2: https://github.com/NixOS/nixpkgs/pull/202022 23 nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05";
24 nixpkgs.url = "github:NixOS/nixpkgs/445f264";
25 flake-utils.url = "github:numtide/flake-utils"; 24 flake-utils.url = "github:numtide/flake-utils";
26 flaky-utils.url = "git+https://cgit.pacien.net/libs/flaky-utils"; 25 flaky-utils.url = "git+https://cgit.pacien.net/libs/flaky-utils";
27 }; 26 };
@@ -29,13 +28,13 @@
29 outputs = { self, nixpkgs, flake-utils, flaky-utils }: 28 outputs = { self, nixpkgs, flake-utils, flaky-utils }:
30 flake-utils.lib.eachDefaultSystem (system: let 29 flake-utils.lib.eachDefaultSystem (system: let
31 pkgs = nixpkgs.legacyPackages.${system}; 30 pkgs = nixpkgs.legacyPackages.${system};
32 ldgalleryVersion = "2.2"; 31 ldgalleryVersion = "2.3";
33 devTools = with pkgs; [ 32 devTools = with pkgs; [
34 # generic 33 # generic
35 tmux 34 tmux
36 35
37 # viewer 36 # viewer
38 nodejs-16_x 37 nodejs-18_x
39 yarn 38 yarn
40 39
41 # compiler 40 # compiler