summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 0207949..034d857 100644
--- a/flake.nix
+++ b/flake.nix
@@ -65,12 +65,12 @@
65 65
66 # Everything combined 66 # Everything combined
67 default = runCommand "combined" { } '' 67 default = runCommand "combined" { } ''
68 mkdir -p "$out" 68 cp -Lr --no-preserve=mode ${website-public} "$out"
69 cp -Lr ${pdf-slides} "$out/slides" 69 cp -Lr --no-preserve=mode ${website-private} "$out/${solutionsSecret}"
70 cp -Lr ${pdf-exercises} "$out/exercises" 70 cp -Lr ${pdf-slides}/* "$out/lectures"
71 cp -Lr ${pdf-solutions} "$out/solutions" 71 cp -Lr ${pdf-exercises}/* "$out/exercises"
72 cp -Lr ${website-public} "$out/website" --no-preserve=mode 72 cp -Lr ${pdf-slides}/* "$out/${solutionsSecret}/lectures"
73 cp -Lr ${website-private} "$out/website/${solutionsSecret}" 73 cp -Lr ${pdf-solutions}/* "$out/${solutionsSecret}/exercises"
74 ''; 74 '';
75 }; 75 };
76 76