aboutsummaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorpacien2022-11-02 01:26:51 +0100
committerpacien2022-11-02 01:26:51 +0100
commitad6b9f97570a21b00852631797fb3857bc6ecb23 (patch)
tree2c649aadfbc828f02e6bb622b418b17ea1ff40ff /app/CMakeLists.txt
parent234b97c14fa8df899291b760602b9bfc7abdad36 (diff)
downloadtincapp-ad6b9f97570a21b00852631797fb3857bc6ecb23.tar.gz
deps: update libressl 3.5.3 -> 3.6.1
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 93dc7c9..4def983 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -1,5 +1,5 @@
1# Tinc App, an Android binding and user interface for the tinc mesh VPN daemon 1# Tinc App, an Android binding and user interface for the tinc mesh VPN daemon
2# Copyright (C) 2017-2021 Pacien TRAN-GIRARD 2# Copyright (C) 2017-2022 Pacien TRAN-GIRARD
3# 3#
4# This program is free software: you can redistribute it and/or modify 4# This program is free software: you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
@@ -43,8 +43,8 @@ ExternalProject_Add(lzo
43) 43)
44 44
45ExternalProject_Add(libressl 45ExternalProject_Add(libressl
46 URL https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.5.3.tar.gz 46 URL https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.6.1.tar.gz
47 URL_HASH SHA256=3ab5e5eaef69ce20c6b170ee64d785b42235f48f2e62b095fca5d7b6672b8b28 47 URL_HASH SHA256=acfac61316e93b919c28d62d53037ca734de85c46b4d703f19fd8395cf006774
48 CONFIGURE_COMMAND <SOURCE_DIR>/configure ${xCONFIG} --disable-shared 48 CONFIGURE_COMMAND <SOURCE_DIR>/configure ${xCONFIG} --disable-shared
49 BUILD_COMMAND make -j8 -C crypto 49 BUILD_COMMAND make -j8 -C crypto
50 INSTALL_COMMAND make -C crypto install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} && 50 INSTALL_COMMAND make -C crypto install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} &&