aboutsummaryrefslogtreecommitdiff
path: root/app/build.gradle
diff options
context:
space:
mode:
authorpacien2018-02-10 14:16:15 +0100
committerpacien2018-02-10 14:16:15 +0100
commit87ec3620d2259064831356c2f4000ae591756fd2 (patch)
tree9312da1d357fdd3790d5b80af221653696b23089 /app/build.gradle
parentd1c39ba87bb32308c2d3a7a749abffeb773541ef (diff)
downloadtincapp-87ec3620d2259064831356c2f4000ae591756fd2.tar.gz
Reformat code
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle94
1 files changed, 47 insertions, 47 deletions
diff --git a/app/build.gradle b/app/build.gradle
index 1e96fdc..4b11a3e 100644
--- a/app/build.gradle
+++ b/app/build.gradle
@@ -3,66 +3,66 @@ apply plugin: 'kotlin-android'
3apply plugin: 'kotlin-android-extensions' 3apply plugin: 'kotlin-android-extensions'
4 4
5android { 5android {
6 compileSdkVersion 25 6 compileSdkVersion 25
7 buildToolsVersion '26.0.2' 7 buildToolsVersion '26.0.2'
8 8
9 defaultConfig { 9 defaultConfig {
10 applicationId "org.pacien.tincapp" 10 applicationId "org.pacien.tincapp"
11 minSdkVersion 21 11 minSdkVersion 21
12 targetSdkVersion 21 12 targetSdkVersion 21
13 multiDexEnabled true 13 multiDexEnabled true
14 versionCode 7 14 versionCode 7
15 versionName "0.7" 15 versionName "0.7"
16 ndk { 16 ndk {
17 abiFilters 'x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'arm64-v8a' 17 abiFilters 'x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'arm64-v8a'
18 } 18 }
19 } 19 }
20 20
21 buildTypes { 21 buildTypes {
22 release { 22 release {
23 minifyEnabled true 23 minifyEnabled true
24 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' 24 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
25 } 25 }
26 } 26 }
27 27
28 externalNativeBuild { 28 externalNativeBuild {
29 cmake { 29 cmake {
30 path "CMakeLists.txt" 30 path "CMakeLists.txt"
31 } 31 }
32 } 32 }
33 33
34 lintOptions { 34 lintOptions {
35 disable 'MissingTranslation' 35 disable 'MissingTranslation'
36 } 36 }
37} 37}
38 38
39dependencies { 39dependencies {
40 compile fileTree(dir: 'libs', include: ['*.jar']) 40 compile fileTree(dir: 'libs', include: ['*.jar'])
41 41
42 compile 'com.android.support:appcompat-v7:25.4.0' 42 compile 'com.android.support:appcompat-v7:25.4.0'
43 compile 'com.android.support:design:25.4.0' 43 compile 'com.android.support:design:25.4.0'
44 compile 'com.android.support:support-v4:25.4.0' 44 compile 'com.android.support:support-v4:25.4.0'
45 compile 'com.android.support:recyclerview-v7:25.4.0' 45 compile 'com.android.support:recyclerview-v7:25.4.0'
46 compile 'com.android.support.constraint:constraint-layout:1.0.2' 46 compile 'com.android.support.constraint:constraint-layout:1.0.2'
47 47
48 compile('org.apache.commons:commons-configuration2:2.1.1') { 48 compile('org.apache.commons:commons-configuration2:2.1.1') {
49 exclude group: 'commons-logging', module: 'commons-logging' 49 exclude group: 'commons-logging', module: 'commons-logging'
50 } 50 }
51 compile('commons-beanutils:commons-beanutils:1.9.3') { 51 compile('commons-beanutils:commons-beanutils:1.9.3') {
52 exclude group: 'commons-logging', module: 'commons-logging' 52 exclude group: 'commons-logging', module: 'commons-logging'
53 } 53 }
54 54
55 compile 'org.bouncycastle:bcpkix-jdk15on:1.57' 55 compile 'org.bouncycastle:bcpkix-jdk15on:1.57'
56 56
57 compile 'net.sourceforge.streamsupport:streamsupport-cfuture:1.5.5' 57 compile 'net.sourceforge.streamsupport:streamsupport-cfuture:1.5.5'
58 58
59 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" 59 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version"
60} 60}
61 61
62repositories { 62repositories {
63 mavenCentral() 63 mavenCentral()
64 jcenter() 64 jcenter()
65 maven { 65 maven {
66 url "https://maven.google.com" 66 url "https://maven.google.com"
67 } 67 }
68} 68}