aboutsummaryrefslogtreecommitdiff
path: root/app/build.gradle
diff options
context:
space:
mode:
authorPacien TRAN-GIRARD2017-06-30 10:21:51 +0200
committerPacien TRAN-GIRARD2017-06-30 10:21:51 +0200
commitc89016e7427defd1f8a095d7aeb30292a42fad92 (patch)
treeaec80e6f501824f966ea727d2f6e102a75e9655f /app/build.gradle
parent94d77ce43152a4e144417d8d5cfff363f65c904e (diff)
downloadtincapp-c89016e7427defd1f8a095d7aeb30292a42fad92.tar.gz
Conversion to Kotlin
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle15
1 files changed, 7 insertions, 8 deletions
diff --git a/app/build.gradle b/app/build.gradle
index 33514ea..840289d 100644
--- a/app/build.gradle
+++ b/app/build.gradle
@@ -1,5 +1,6 @@
1apply plugin: 'com.android.application' 1apply plugin: 'com.android.application'
2apply plugin: 'me.tatarka.retrolambda' 2apply plugin: 'kotlin-android'
3apply plugin: 'kotlin-android-extensions'
3 4
4android { 5android {
5 compileSdkVersion 25 6 compileSdkVersion 25
@@ -7,10 +8,9 @@ android {
7 defaultConfig { 8 defaultConfig {
8 applicationId "org.pacien.tincapp" 9 applicationId "org.pacien.tincapp"
9 minSdkVersion 21 10 minSdkVersion 21
10 targetSdkVersion 25 11 targetSdkVersion 21
11 versionCode 1 12 versionCode 1
12 versionName "0.1-preview" 13 versionName "0.1-preview"
13 testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
14 } 14 }
15 buildTypes { 15 buildTypes {
16 release { 16 release {
@@ -18,10 +18,6 @@ android {
18 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' 18 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
19 } 19 }
20 } 20 }
21 compileOptions {
22 sourceCompatibility JavaVersion.VERSION_1_8
23 targetCompatibility JavaVersion.VERSION_1_8
24 }
25 externalNativeBuild { 21 externalNativeBuild {
26 cmake { 22 cmake {
27 path "CMakeLists.txt" 23 path "CMakeLists.txt"
@@ -45,5 +41,8 @@ dependencies {
45 exclude group: 'commons-logging', module: 'commons-logging' 41 exclude group: 'commons-logging', module: 'commons-logging'
46 } 42 }
47 43
48 compile 'com.annimon:stream:1.1.5' 44 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version"
45}
46repositories {
47 mavenCentral()
49} 48}