aboutsummaryrefslogtreecommitdiff
path: root/app/build.gradle
diff options
context:
space:
mode:
authorpacien2018-03-29 14:40:53 +0200
committerpacien2018-03-29 14:40:53 +0200
commitea4cd3a2a5f90762fc529a3d3fd2d2fbcd0d9cc4 (patch)
tree09d7bc4ed756c2b49330eb6a01d8360c1dbde8e1 /app/build.gradle
parent18b8c8fe1b370c47978e7ae0342139d556969f00 (diff)
downloadtincapp-ea4cd3a2a5f90762fc529a3d3fd2d2fbcd0d9cc4.tar.gz
Update build tools
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle36
1 files changed, 14 insertions, 22 deletions
diff --git a/app/build.gradle b/app/build.gradle
index 8197d60..46a5dbd 100644
--- a/app/build.gradle
+++ b/app/build.gradle
@@ -4,11 +4,11 @@ apply plugin: 'kotlin-android-extensions'
4 4
5android { 5android {
6 compileSdkVersion 25 6 compileSdkVersion 25
7 buildToolsVersion '26.0.2'
8 7
9 defaultConfig { 8 defaultConfig {
10 applicationId 'org.pacien.tincapp' 9 applicationId 'org.pacien.tincapp'
11 minSdkVersion 21 10 minSdkVersion 21
11 //noinspection OldTargetApi
12 targetSdkVersion 21 12 targetSdkVersion 21
13 multiDexEnabled true 13 multiDexEnabled true
14 versionCode 12 14 versionCode 12
@@ -30,37 +30,29 @@ android {
30 path 'CMakeLists.txt' 30 path 'CMakeLists.txt'
31 } 31 }
32 } 32 }
33
34 lintOptions {
35 // 20180212:
36 // Lint checks on Kotlin files only work from the Android Studio IDE.
37 // They currently do not run when you run lint directly from Gradle.
38 // https://developer.android.com/studio/preview/kotlin-issues.html
39 disable 'OnClick', 'UnusedResources'
40 }
41} 33}
42 34
43dependencies { 35dependencies {
44 compile fileTree(dir: 'libs', include: ['*.jar']) 36 implementation fileTree(dir: 'libs', include: ['*.jar'])
45 37
46 compile 'com.android.support:appcompat-v7:25.4.0' 38 implementation 'com.android.support:appcompat-v7:25.4.0'
47 compile 'com.android.support:design:25.4.0' 39 implementation 'com.android.support:design:25.4.0'
48 compile 'com.android.support:support-v4:25.4.0' 40 implementation 'com.android.support:support-v4:25.4.0'
49 compile 'com.android.support:recyclerview-v7:25.4.0' 41 implementation 'com.android.support:recyclerview-v7:25.4.0'
50 compile 'com.android.support.constraint:constraint-layout:1.0.2' 42 implementation 'com.android.support.constraint:constraint-layout:1.0.2'
51 43
52 compile('org.apache.commons:commons-configuration2:2.1.1') { 44 implementation('org.apache.commons:commons-configuration2:2.1.1') {
53 exclude group: 'commons-logging', module: 'commons-logging' 45 exclude group: 'commons-logging', module: 'commons-logging'
54 } 46 }
55 compile('commons-beanutils:commons-beanutils:1.9.3') { 47 implementation('commons-beanutils:commons-beanutils:1.9.3') {
56 exclude group: 'commons-logging', module: 'commons-logging' 48 exclude group: 'commons-logging', module: 'commons-logging'
57 } 49 }
58 50
59 compile 'org.bouncycastle:bcpkix-jdk15on:1.57' 51 implementation 'org.bouncycastle:bcpkix-jdk15on:1.57'
60 compile 'net.sourceforge.streamsupport:streamsupport-cfuture:1.5.5' 52 implementation 'net.sourceforge.streamsupport:streamsupport-cfuture:1.5.5'
61 compile 'org.slf4j:slf4j-api:1.7.25' 53 implementation 'org.slf4j:slf4j-api:1.7.25'
62 compile 'com.github.tony19:logback-android:1.1.1-9' 54 implementation 'com.github.tony19:logback-android:1.1.1-9'
63 compile "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version" 55 implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
64} 56}
65 57
66repositories { 58repositories {