aboutsummaryrefslogtreecommitdiff
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 1962fbf..c983539 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -1,5 +1,5 @@
1# Tinc App, an Android binding and user interface for the tinc mesh VPN daemon 1# Tinc App, an Android binding and user interface for the tinc mesh VPN daemon
2# Copyright (C) 2017-2020 Pacien TRAN-GIRARD 2# Copyright (C) 2017-2022 Pacien TRAN-GIRARD
3# 3#
4# This program is free software: you can redistribute it and/or modify 4# This program is free software: you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
@@ -43,8 +43,8 @@ ExternalProject_Add(lzo
43) 43)
44 44
45ExternalProject_Add(libressl 45ExternalProject_Add(libressl
46 URL https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.1.4.tar.gz 46 URL https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.7.3.tar.gz
47 URL_HASH SHA256=414c149c9963983f805a081db5bd3aec146b5f82d529bb63875ac941b25dcbb6 47 URL_HASH SHA256=7948c856a90c825bd7268b6f85674a8dcd254bae42e221781b24e3f8dc335db3
48 CONFIGURE_COMMAND <SOURCE_DIR>/configure ${xCONFIG} --disable-shared 48 CONFIGURE_COMMAND <SOURCE_DIR>/configure ${xCONFIG} --disable-shared
49 BUILD_COMMAND make -j8 -C crypto 49 BUILD_COMMAND make -j8 -C crypto
50 INSTALL_COMMAND make -C crypto install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} && 50 INSTALL_COMMAND make -C crypto install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} &&
@@ -54,10 +54,8 @@ ExternalProject_Add(libressl
54 54
55ExternalProject_Add(tinc 55ExternalProject_Add(tinc
56 DEPENDS lzo libressl 56 DEPENDS lzo libressl
57 URL https://github.com/gsliepen/tinc/archive/f5223937e62e1cc5e9b3d322490dd3af8d666750.tar.gz 57 URL https://tinc-vpn.org/packages/tinc-1.1pre18.tar.gz
58 URL_HASH SHA256=3fe923e8fbb1e0192986039e91d6945ffbbe326ee8c2c0a13bacf80e87dad4a9 58 URL_HASH SHA256=2757ddc62cf64b411f569db2fa85c25ec846c0db110023f6befb33691f078986
59 # TODO: remove patch once merged in upstream (https://github.com/gsliepen/tinc/pull/251)
60 PATCH_COMMAND patch -p1 < ${PROJECT_SOURCE_DIR}/src/main/c/0001-tincctl-restrict-umask-argument-for-FORTIFY.patch
61 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> && 59 CONFIGURE_COMMAND autoreconf -fsi <SOURCE_DIR> &&
62 <SOURCE_DIR>/configure ${xCONFIG} 60 <SOURCE_DIR>/configure ${xCONFIG}
63 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local 61 --with-openssl=${CMAKE_CURRENT_BINARY_DIR}/usr/local
@@ -67,9 +65,11 @@ ExternalProject_Add(tinc
67 BUILD_COMMAND make -j8 -C src 65 BUILD_COMMAND make -j8 -C src
68 INSTALL_COMMAND make -C src install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} && 66 INSTALL_COMMAND make -C src install DESTDIR=${CMAKE_CURRENT_BINARY_DIR} &&
69 ${CMAKE_COMMAND} -E copy 67 ${CMAKE_COMMAND} -E copy
70 ${CMAKE_CURRENT_BINARY_DIR}/usr/local/sbin/tinc ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libtinc.so && 68 ${CMAKE_CURRENT_BINARY_DIR}/usr/local/sbin/tinc
69 ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libtinc.so &&
71 ${CMAKE_COMMAND} -E copy 70 ${CMAKE_COMMAND} -E copy
72 ${CMAKE_CURRENT_BINARY_DIR}/usr/local/sbin/tincd ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libtincd.so && 71 ${CMAKE_CURRENT_BINARY_DIR}/usr/local/sbin/tincd
72 ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libtincd.so &&
73 rm -r <BINARY_DIR> 73 rm -r <BINARY_DIR>
74) 74)
75 75