aboutsummaryrefslogtreecommitdiff
path: root/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle49
1 files changed, 49 insertions, 0 deletions
diff --git a/app/build.gradle b/app/build.gradle
new file mode 100644
index 0000000..33514ea
--- /dev/null
+++ b/app/build.gradle
@@ -0,0 +1,49 @@
1apply plugin: 'com.android.application'
2apply plugin: 'me.tatarka.retrolambda'
3
4android {
5 compileSdkVersion 25
6 buildToolsVersion '25.0.0'
7 defaultConfig {
8 applicationId "org.pacien.tincapp"
9 minSdkVersion 21
10 targetSdkVersion 25
11 versionCode 1
12 versionName "0.1-preview"
13 testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
14 }
15 buildTypes {
16 release {
17 minifyEnabled true
18 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
19 }
20 }
21 compileOptions {
22 sourceCompatibility JavaVersion.VERSION_1_8
23 targetCompatibility JavaVersion.VERSION_1_8
24 }
25 externalNativeBuild {
26 cmake {
27 path "CMakeLists.txt"
28 }
29 }
30}
31
32dependencies {
33 compile fileTree(dir: 'libs', include: ['*.jar'])
34
35 compile 'com.android.support:appcompat-v7:25.3.1'
36 compile 'com.android.support:design:25.3.1'
37 compile 'com.android.support:support-v4:25.3.1'
38 compile 'com.android.support:recyclerview-v7:25.3.1'
39 compile 'com.android.support.constraint:constraint-layout:1.0.0-alpha4'
40
41 compile('org.apache.commons:commons-configuration2:2.1.1') {
42 exclude group: 'commons-logging', module: 'commons-logging'
43 }
44 compile('commons-beanutils:commons-beanutils:1.9.3') {
45 exclude group: 'commons-logging', module: 'commons-logging'
46 }
47
48 compile 'com.annimon:stream:1.1.5'
49}